Get ahead in all things VET. Become a member today.
     
Sign up or sign in

How can we help you?

System Requirements

Q: What kind of operating system do I require?
A: At a minimum you will require:

  • A personal computer or laptop to view the presentation (Mac or PC)
  • Ability to receive audio (either using a telephone to dial-in or mic and speakers (headset) connected to your computer)

For PC-Based Organisers and Attendees

  • Required: Windows® 7-10, Vista, XP or 2003 Server (Linux is not supported)
  • Required: Internet Explorer® V8 or Later, Mozilla® Firefox® V34 or Later, Google® Chrome® V34 or later or Microsoft Edge V12 or later
  • 5.0 or newer (JavaScriptTM and JavaTM enabled) . If needed, download Java here.
  • Required: Internet connection, with cable modem, DSL or better recommended
  • Recommended: Dual core 2.4GHz CPU or faster with at least 2 GB of RAM

For Mac-Based Organisers and Attendees

  • Required: Mac OS® X 10.5 (Leopard®), OS X 10.6 (Snow Leopard®), OS X 10.7 (Lion®)
  • Required: SafariTM 3.0 or newer, or Firefox 3.0 or newer; (JavaScript and Java enabled; ChromeTM is not supported)
  • Internet Connection Required: Cable modem, DSL or better recommended
  • Required: Intel processor with 512 MB of RAM or better recommended

Contact us

Need some help? Visit our help section to get answers to your questions.

start livechat